Перейти к контенту

H_A_N

Пользователи
  • Число публикаций

    21
  • Регистрация

  • Последнее посещение

Достижения H_A_N

  1. У меня есть потребность создать ленту RSS для форума и галереи. Требуется реализовать чтобы в RSS могли попадать не только первые посты из тем, в разделах который указаны в ACP, но и посты вручную отмеченные администратором. Кто сможет реализовать нечто подобное? (речь идет про IPB 4.2.7 - 4.3)
  2. Сегодня на форум 3.1.4 в папку uploads/profile смогли загрузил следующий файл (но только с расширением .JPG) photo-33 - копия (2).php После этого форум мягко говоря перестал корректно функционировать. Кто-то сталкивался уже с подобным? Какие есть рекомендации чтобы в будущем избежать печальных последствий от загрузки всякой .... под видом .JPG? P.S. Раскодировать эту хрень и понять что там лично я пока не смог, может у кого есть мысли что это и как это.
  3. H_A_N

    медиа тэг

    А в ответ тишина ((( Может кто-то еще сможет написать правильные медиа-теги для ютуба и остальных видео хостингов?
  4. H_A_N

    media теги

    В с некоторых пор перестало работать Video c Mail.ru Код написан как в посте №2 Это что-то у меня или у mail.ru что-то поменялось?
  5. Я тоже официальная тех. поддержка =) Просто меня в наказание отправили помогать на форуме. В АЦ пароли просят, чтобы настройки проверить, 6 раз просят, потому что не запоминают. Настройки они сначала 2 раза просят самим проверить, потом просят пароль в АЦ (хотя у нас еще 2 открытые заявки на починку висят и в них эти же пароли висят). Дело не в запоминании, а в желании помочь и ответить по делу. Я с 18 ноября по 24 ноября переписывался по поводу раздела "Непрочитанные уведомления", 4 раза медлено и по пунктам писал что где и как, но ответ по делу получил только сегодня. Сначала было уточните, потом "Указанной проблемы не наблюдаем", хотя если прочитать ВНИМАТЕЛЬНО что написано в запросе в АЦ то там разве что координатов пикселей на экране нет, все разжеванно очень подробно (особенно для тех кто форум знает), ответы же считается нормальным давать считаю что все пользователь/покупатель форума на 99% должны знать движек и где что находится. Честно скажу после 9 запросов за две недели, складывается впечатление что есть правило раз в 1-2 дня надо обязательно ответить, что неважно, главное ответить и поставить галочку "ответ обработан". А потом если очень достанут, сами не разберутся и само не рассосется, то когда будет время глянем. Мне по крайней мере за 5 лет и за порядка 20 обращений в АЦ всего пару раз удалось получить относительно быстро (раньше чем через сутки, другие) полезный ответ. Ладно, будем надеятся что я ошибаюсь и это на мне так недельная борьба с форумом сказывается. Еще раз спасибо за помощь !!!
  6. ЗАРАБОТАЛО !!! Большое спасибо за помощь и плюсов Вам в репутацию !!! Очень жаль что официальной тех.поддержке потребовалось 3 дня только для того чтобы в шестой раз за последнюю неделю снова запросить у нас пароль в АЦ. А сколько бы прошло времени до того момента пока бы ненашлось что все так не очень сложно, даже страшно представить. Еще раз Вам СПАСИБО !!!
  7. НЕТ недошло !!! ни когда закоментирована строка: "$mail_header .= "X-Sender-IP: $ip\r\n";" ни когда раскоментированна. Но на @gmail.com все письма дошли.
  8. Попробовал предложенным скриптом, письмо недошло. Попробовал нашим тестовым скриптом <? error_reporting(E_ALL); $mess="Письмо с сайта"; if (getenv('HTTP_X_FORWARDED_FOR')) { $ip=getenv('HTTP_X_FORWARDED_FOR'); } { $ip=getenv('REMOTE_ADDR'); } $host = gethostbyaddr("$ip"); if (!$ip){$ip = "unknown";} if (!$host){$host = "unknown";} $mail_header = ""; $email_user = "имя@list.ru"; $email = "имя@gmail.com"; $mail_header .= "MIME-Version: 1.0\r\n"; $mail_header .= "X-Sender-IP: $ip\r\n"; $mail_header .= "Content-Type: text/plain; charset='windows-1251'\r\n"; $mail_header .= "From: site <" . $email . ">"; $mail_header=mb_convert_encoding($mail_header, "CP1251", "auto"); $mail_subject=mb_convert_encoding("Test", "CP1251", "auto"); $mail_message=mb_convert_encoding($mess, "CP1251", "auto"); $mail_to=mb_convert_encoding($email_user, "CP1251", "auto"); if (mail($mail_to, $mail_subject, $mail_message, $mail_header, "-f $email")) { echo "<br>Письмо отправлено!<br>"; } else { echo "<br>Ошибка! Почтовый сервер не смог обработать Ваше сообщение"; } ?> Письмо с нашего скрипта ДОШЛО СРАЗУ !!!! Есть подозрение что дело в полях, их кто-то неможет "переварить" $subject = '?UTF-8?B.......... From: \"=?UTF-8?B.............
  9. Сделал, вот какой файл получился =?UTF-8?B?0JLQvtC/0YDQvtGBINC90LDRh9Cw0Lsg0L3QvtCy0YPRjiDQsdC10YHQtdC00YMg0YEg0LLQsNC80Lg=?= ------------ MIME-Version: 1.0 Date: Wed, 24 Nov 2010 19:23:34 +0000 Return-Path: домен@домен.ru X-Priority: 3 X-MSMail-Priority: Normal X-Mailer: IPS PHP Mailer From: "=?UTF-8?B?0KTQvtGA0YPQvCDQvtGF0L7RgtC90LjQutC+0LIg0Lgg0YDRi9Cx0LDQutC+0LIg0JzQntCe0LjQoA==?=" <домен@домен.ru> Content-type: text/plain; charset="UTF-8" H_A_N, Вопрос отправил вам сообщение с заголовком "ыва ыва ыв". Вопрос сказал: ====================================================================== ыва ыв аыв Вы можете просмотреть беседу с ним, пройдя по указанной ниже ссылке: http://www.домен.ru/forum/index.php?app=members&module=messaging&section=view&do=showConversation&topicID=6686#msg6803
  10. Вопрос: где такие водятся, как их посмотреть? В логах сервера все ОК, все письма которые были, отправлены, писем про которые я говорю там нет! В логах e-mail ошибок (АЦ / Система / Настройки и инструменты / Список журналов / Журнал ошибок e-mail ) Всего 3 записи: первая: Архив личной переписки Невозможно отправить сообщение 16 Ноя 2010 01:40 вторая: =?windows-1251?Q?=CD?= Невозможно отправить сообщение 02 Ноя 2010 10:25 третья: такая же за 02 Ноя 2010 Форум обновлялся 15-16 ноября Что именно и где именно смотреть еще?
  11. Обновили форум до 3.1.4 Проблема с неуходом почты на MAIL.RU осталась Еще идеи есть?
  12. Стоит но страшно ))) Вдруг еще неделю будем форум от ошибок лечить А если серьезно, сомневаюсь что дело в этом, у людей в 3.1.2 - 3.1.3 проблем небыло, по крайней мере никто тут не жаловался, поэтому работать должно. До 3.1.4 хотели обновится через недельку, другую, третью, пока кто-то другой бета тестером поработает. 3.1.3 вышла в начале месяца, мы подождали пару недель вроде никто сильно не жаловался, поставили, а тут такое (в CSS кое где пути в одинарных кавычках стоят и т.д.)
  13. Неделю назад обновили форум с 2.3.6 до 3.1.3 Почти неделя ушла на исправление ошибок в дистрибутиве из клиент-центра, отладку сервера и на привыкание ко всему новому. В основном все заработало, но вылезла проблема с почтой (уведомлениями на эл. ящики), тех. поддержка уже несколько дней дельного совета где искать ошибка дать не может. Может кто посоветует где именно искать ошибку? Итак суть проблемы: с форума не доходят письма на mail.ru и его зеркала (bk.ru, list.ru ...) при: 1. активизации акка 2. восстановлении пароля 3. уведомлении о подписках и так далее Мы проверили функцию mail() письма с самого сервера уходят и доходят до адресата. Не доходят они только с форума. Поясню - письма на MAIL.RU не уходят только(!) из скрипта форума. В спам базе MAIL.RU нас нет. Форум находится на том же IP, что и основной сайт. В АЦ, в журнале есть ошибки отправки (но всего по трем письмам, а отправленны были сотни). Картину они не проясняют. При этом проверено если у пользователя ящик на @yandex.ru, @gmail, все письма доходят без проблем и задержек !!! Где искать корень проблемы? Заранее спасибо
  14. Странно что никто ответить не смог (или не захотел), подозреваю что с такой ошибкой столкнулся не один я. Ну да ладно, для тех у кого такая же проблемма напишу как я это решил. По наводке более разговорчивых людей с другого форума посвященого Инвижену, я начал проверять синтаксис в CSS. Синтансис оказался в порядке, но выяснилось что если в скине с ошибкой заменить основной CSS (Админка, Внешний вид, Изменить таблицу стилей CSS) на CSS из дефолтного скина, то ошибка исчезает При детальном сравнении оказалось что в скине с ошибкой отсутствуют строки #ipd-msg-wrapper { display: none; width: 220px; } #ipd-msg-inner { width:100%; height:45px; padding: 6px 4px 4px 4px; margin: 0px; text-align:center; color: #000; border: 1px solid; border-color:#ccc #666 #666 #ccc; background-color: #FCF8C7; filter:alpha(opacity=75); opacity:.75 } #ipd-msg-title { width: 100%; height:20px; margin: 0px; padding: 6px 4px 4px 4px; background: transparent url(style_images/<#IMG_DIR#>/css_pp_header.gif); border: 1px solid #3A4F6C; border-bottom: 0px; color: #FFF; } .linked-image { margin: 0px; padding: 0px; border: 0px; } .resized-linked-image { margin: 1px 0px 0px 0px; padding: 0px; background-color: #000; border: 0px; color: #FFF; font-size: 10px; width: auto; -moz-border-radius-topleft: 7px; -moz-border-radius-topright: 7px; } .resized-linked-image-zoom { width: 200px; height: 30px; filter:alpha(opacity=85); opacity:.85; background-color: #FFF; padding-top: 6px; padding-left: 5px; top: 0px; left: 0px; position: absolute; display: none; } Добавив этот код в CSS со скином, ошибка исчезла. В общем дело оказалось в том что скин разрабатыватся несколько лет назад и тогда же ставился на форум, а потом меняя версии форума нужно было поправлять и скин.
×
×
  • Создать...