Перейти к контенту

IPB 1.3 vs PHP 5


Рекомендуемые сообщения

Зашёл сегодня случайно на invisionboard.com и увидел там следующую надпись:

NOTE: IPB 1.3.1 WILL NOT WORK WITH PHP 5

 

Кто-нибудь знает, почему? :D

Ссылка на комментарий
Поделиться на других сайтах

видимо просто не гарантируют работу с PHP 5, поскольку вопросами с белыми страницами достают не только нас :D
Ссылка на комментарий
Поделиться на других сайтах

А второй кстати с PHP5 корректно работает? И что нужно чтоб код на PHP5 работал? Его самого я уже скачал, но методом тыка изучать не хочется :D
Ссылка на комментарий
Поделиться на других сайтах

Я мало смыслю в PHP но проблема с форумом в том что, он написан на классах, а в 5 версии всё переработали, в плане классов. И ещё, можно не переживать, PHP 5 , будет на хостингах не раньше чем через год, или даже 2. Пока оно сыро.
Ссылка на комментарий
Поделиться на других сайтах

PHP 5 , будет на хостингах не раньше чем через год, или даже 2.

Сыро не сыро, а некоторые хостинговые компании уже больше месяца кричат что php5 у них уже установлен.

Ссылка на комментарий
Поделиться на других сайтах

а в 5 версии всё переработали, в плане классов.

Откуда такая информация? Что конкретно переработали?

Ссылка на комментарий
Поделиться на других сайтах

На вскидку обработка исключений...

Угу, почитал.

Однако, возвращаясь к названию темы - а как это на IPB-то повлияет? Вот, например, написано, что теперь конструкторы класса по-другому работают - и что, я ставил IPB на PHP5 и всё работает :D (за исключением пустых страниц в профиле, конечно...).

Обратная совместимость же оставлена?

Ссылка на комментарий
Поделиться на других сайтах

  • 2 недели спустя...
Однако, возвращаясь к названию темы - а как это на IPB-то повлияет?

Просмотрел еще раз о новшествах php5 и ненашел ничего такого что помещало работать ipb.

хотя это может быть

Обработка объектов в Zend Engine 2 полностью переработана: повышена производительность и добавлены новые возможности. В предыдущих версиях PHP объекты обрабатывались так же, как и переменные простых типов (например, целочисленные значения или строки). Недостаток такого подхода в том, что при присваивании (или передаче объекта как параметра функции) происходило копирование объекта. При новом подходе, объекты передаются по ссылке, а не по значению (если вам незнакома эта терминология, можете представить себе ссылку как уникальный идентификатор объекта).

 

http://www.php5.ru/php/zend2/

Ссылка на комментарий
Поделиться на других сайтах

  • 2 недели спустя...

Link

Всё и так работает?

Ссылка на комментарий
Поделиться на других сайтах

  • 3 недели спустя...

вот взял свой сервак, поставил апач 2.0 , пхп 5.0

переношу форум 1.3.... индексную пейджу открываает, но не жрет передачу переменных в GET,.... хрен знает в чем дело.

 

 

Да, в конфигцрации стоит register_globals=On...

 

Подумал может в нем дело. доьавил флаг в .htaccess :

php_flag register_globals 0

 

не помогло... ;)

 

То есть проблема в том что index.php?a=2 и т.д. все перекидывает на index.php

 

то бишь парметры не передаются. Кто сталкивался с этим ?

(До этого стоял на php4 , apache 1.3 - проблем не было)

 

 

 

Добавлено в [mergetime]1097845258[/mergetime]

забыл уведомление включиь :D

Ссылка на комментарий
Поделиться на других сайтах

  • 3 недели спустя...

и снова я, ребят вотсам форум http://forum.backgrounds.ru

версия 1.3

php 5.0.1

apache 2.0

mysql 4.0.28

 

думал веже дело в особенности 5ого пхп и его обьектной модели, но че то не помагает...

подскажите чего :D

Если апгрейдить до 2.0 нужно ли будет гарфику редактировать (иконы) пр иусловии что хочется использовать прежние (хотя чатсь все равно как шаблон 2.0) ?

Ссылка на комментарий
Поделиться на других сайтах

constructor

Поскольку у теб на форуме пусто, то тебе лучше вчистую поставить 2.x, а потом просто скин отредактировать под нынешний. При апгрейде ты всё равно безболезненно его не перенесёшь.

Ссылка на комментарий
Поделиться на других сайтах

constructor

из копирайта убрана версия форума. Добавлять свой копирайт можно только после покупки лицензии. У вас она куплена?

Ссылка на комментарий
Поделиться на других сайтах

и снова я, ребят вотсам форум http://forum.backgrounds.ru

версия 1.3

php 5.0.1

apache 2.0

mysql 4.0.2

constructor

©2004 backgrounds.ru 

Invision Power Board © 2003  IPS, Inc.

[Руслан Малашин aka alinmuzh] 
ver. 0.98 alfa

Вот, что у Вас написано в строке копирайтов.

Пока они не будут приведены в полное оответсвие с лицензионным соглашением никто из команды Вам помогать не будет.

Ссылка на комментарий
Поделиться на других сайтах

  • 2 месяца спустя...

Ребят подскажите как быть...

Хостер поставил себе php 5, а Форум на 1,3 стоит...Начался глюк с просмотром профиля пользователя и Файловым Архивом. Причем на локале(там php4,3 стоит) всё ок...

Как бы пофиксить?

Ссылка на комментарий
Поделиться на других сайтах

Начался глюк с просмотром профиля пользователя

Что за глюк? Тот, который у нас описан в FAQ, в теме "Белая страница"?

Ссылка на комментарий
Поделиться на других сайтах

×
×
  • Создать...

Важная информация

Находясь на нашем сайте, вы соглашаетесь на использование файлов cookie, а также с нашим положением о конфиденциальности Политика конфиденциальности и пользовательским соглашением Условия использования.